Identified service disruption
Incident Report for Plentific
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 16:21 BST
Identified
We’ve identified an issue with out platform. Our engineers are working to fix this as quickly as possible.

We'll provide an update as soon as we can.
Posted Apr 19, 2021 - 13:56 BST
This incident affected: Work order management, Properties, Notifications, Reporting, Payments, APIs, and Webhooks.