Investigating service disruption
Incident Report for Plentific
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 11:25 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2023 - 11:16 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 16, 2023 - 11:14 BST
Investigating
We’re currently experiencing service disruption related to our platform. Users may be experiencing issues when using Plentific.

Our Engineering team is working to identify the root cause and implement a solution.

We'll provide an update for you as soon as we can.
Posted Aug 16, 2023 - 10:41 BST
This incident affected: Work order management, Properties, Notifications, Reporting, data and analytics, Payments, APIs, and Webhooks.