Identified service disruption
Incident Report for Plentific
Resolved
We've assessed the fix and users should now see all features working as expected. We're sorry for the inconvenience it caused.

If you're seeing any continued issues, don't hesitate to get in touch with our team.
Posted Mar 01, 2021 - 16:19 GMT
Identified
We’ve identified the issue. Our engineers are working to fix this as quickly as possible.

We'll provide an update as soon as we can.
Posted Mar 01, 2021 - 16:03 GMT
This incident affected: Work order management, Properties, Notifications, Reporting, Payments, APIs, and Webhooks.