Platform down for Agents and Pros
Incident Report for Plentific
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 18:39 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 16, 2021 - 18:09 GMT