Investigating service disruption
Incident Report for Plentific
Resolved
We've assessed the fix and users should now see all features working as expected. We're sorry for the inconvenience it caused.

If you're seeing any continued issues, don't hesitate to get in touch with our team.
Posted Aug 24, 2020 - 13:25 BST
Monitoring
We’ve deployed a fix for the incident.

We’re monitoring to ensure users' experience on the platform returns to normal.

We'll provide an update as soon as we can.
Posted Aug 24, 2020 - 13:20 BST
Investigating
We’re currently experiencing service disruption related to our platform. Users may be experiencing issues when using Plentific.

Our Engineering team is working to identify the root cause and implement a solution.

We'll provide an update for you as soon as we can.
Posted Aug 24, 2020 - 12:16 BST
This incident affected: Work order management, Properties, Notifications, Reporting, Payments, APIs, and Webhooks.