Identified service disruption
Incident Report for Plentific
Resolved
We've assessed the fix and users should now see all features working as expected. We're sorry for the inconvenience it caused.

If you're seeing any continued issues, don't hesitate to get in touch with our team.
Posted Oct 10, 2022 - 17:52 BST
Identified
We’ve identified an issue with the platform. Our engineers are working to fix this as quickly as possible.

We'll provide an update as soon as we can.
Posted Oct 10, 2022 - 17:49 BST
This incident affected: Work order management, Properties, Notifications, Reporting, data and analytics, Payments, APIs, Webhooks, and Sandbox environment.